Welcome Guest,Register Now
Log In

ANT Forum

Welcome guest, please Login or Register

   

Minimum SDK level for Android with ANT API 20120201 ?

RankRankRankRank

Total Posts: 524

Joined 2012-11-15

PM

Hello all,

is there a minimum Android Version required that works with the current ANT API?

The reason I ask is, that my App works fine with ANT API for Android, version 20120201 and Android 4.03.

The same application runs into an Exception on Android 2.1.
Even the Demo App does not work on Android 2.1, but works well on Android 4.03.

If I delete the code for the ANT interface, the rest of the App works fine again on both versions.

Not sure where the error exactly sits. Before or behind the screen.

Any comments or hints are welcome.      
Avatar
RankRank

Total Posts: 39

Joined 2011-06-29

PM

The min SDK for the ANT Radio Service is 1.6, but all of the version checking is handled by the Android framework.

Could you provide some more details on the following:

Type of phone
ANT Radio Service version (can be found under settings > apps)
What function is failing?
What code are you deleting to make it work?