Welcome Guest,Register Now
Log In

ANT Forum

Welcome guest, please Login or Register

   

Simulant+ Crash when running scripts

Rank

Total Posts: 6

Joined 2012-10-15

PM

I just started getting errors when running scripts in Simulant+.

I'm running the Muscle Oxygen Display simulator and I try to run the MD_MO2_001 Command Response script.

Right after I run it, an error message pops up that shows:

Could not find part of the path
'C:\WINDOWS\system32\CertScripts\modules\certPromt.xaml'.

This just started showing up on 2 different machines. I have run scripts previously on both machines so I don't know what could have changed.

I have tried versions 2.3.0 and 2.2.0 of Simulant+ and both now have the error.

Any ideas on how to fix this?

Thanks!      
Rank

Total Posts: 2

Joined 2019-10-15

PM

Hi, I'm bumping this because I have the same problem and wondering if you found an answer. I tried moving the scripts to System32 but it does not help. I am new to this and not sure where the path is coming from to edit it. It is not located in the module files as far as I can see, is it some embedded Windows library?      
RankRankRankRank

Total Posts: 139

Joined 2012-06-27

PM

The file it is looking for is certPrompt.xaml in the CertScripts/modules folder. I believe this is coming from the load in certification_prompts.py.

Please check that you have not moved these scripts relative to the exe.

You may also try setting the absolute path to the xaml instead of relative at
"self.prompt = self._load_xaml('CertScripts/modules/certPrompt.xaml')".

Ian      

Signature

Ian Haigh