Welcome Guest,Register Now
Log In

ANT Forum

Welcome guest, please Login or Register

   

Android v10 ANT+ solution?

Rank

Total Posts: 1

Joined 2020-05-09

PM

Updated my Galaxy S10+ OS from Android v9 to Android v10. In doing so, lost all ANT+ connectivity (cycling sensors). ANT Tester app shows that all is well. Any solutions?
Thanks in advance.
-Bill      

Image Attachments

20200511_223544.jpg

Click thumbnail to see full-size image

Rank

Total Posts: 7

Joined 2013-03-12

PM

Not sure it is an ANT+ Services issue, or a Samsung one. Many of the users of my apps are complaining ANT+ being broken with the latest Android 10 update in their Samsung devices. Exclusively happens with Samsung so far as far as I am concerned.      
Rank

Total Posts: 7

Joined 2013-03-12

PM

But it is also possible that, so far, no Sony Android 9 device has got an Android 10 update.      
Avatar
RankRankRankRank

Total Posts: 730

Joined 2012-09-14

PM

There is an updated ANT+ Plugin Library which is required for Android 10 on GitHub related to this issue:

https://github.com/ant-wireless/ANT-Android-SDKs/issues/14

Please update it and let us know if it solves the issue for your users on Samsung's Android 10 update.      
Rank

Total Posts: 7

Joined 2013-03-12

PM

My app is already using antpluginlib_3-8-0.aar and it is having issues with Samsung devices with the latest Android 10 updates.
However it is fine with other Android 10 devices. I use a Google Pixel 3A with Android 10, and I can't replicate the issue.