Welcome Guest,Register Now
Log In

ANT Forum

Welcome guest, please Login or Register

You are here: Forum Home → ANT Developer’s Forums → ANTWareII → Thread

   

ANTWarell not pairing with bike trainer

Rank

Total Posts: 3

Joined 2018-09-16

PM

I can connect with my bike trainer (Tacx Flow Smart) using ANTWarell if I input the relevant channel ID data but I cannot get a connection when using pairing and with channel ID data all set to 0. Can anyone tell me what the problem might be?

Mike      
RankRankRankRank

Total Posts: 283

Joined 2012-06-27

PM

Can you give more detail for what you mean by "using pairing"? If you are referring to the "Pairing" checkbox, then this is your issue. This translates to the pairing bit (bit 7 of the device type). This bit is not used by the FE profile. When checked, ANTWareII will only connect to devices broadcasting device type 145 (0x91). Therefore it will not find your trainer.      

Signature

Ian Haigh

RankRankRankRank

Total Posts: 283

Joined 2012-06-27

PM

I recommend using SimulANT+ to connect to your trainer instead for most purposes.      

Signature

Ian Haigh

Rank

Total Posts: 3

Joined 2018-09-16

PM

haighi - 25 January 2021 01:22 PM
Can you give more detail for what you mean by "using pairing"? If you are referring to the "Pairing" checkbox, then this is your issue. This translates to the pairing bit (bit 7 of the device type). This bit is not used by the FE profile. When checked, ANTWareII will only connect to devices broadcasting device type 145 (0x91). Therefore it will not find your trainer.


Yes I was checking the 'pairing' box. Thank you for your help.

Mike      
Rank

Total Posts: 3

Joined 2018-09-16

PM

haighi - 25 January 2021 01:23 PM
I recommend using SimulANT+ to connect to your trainer instead for most purposes.


OK thanks I'll give this a try.
Mike      
Rank

Total Posts: 5

Joined 2021-02-26

PM

Did you manage to connect to the trainer? Does the same apply to my Elite Suito?

Thanks for the reply      
RankRankRankRank

Total Posts: 283

Joined 2012-06-27

PM

For all ANT+ FE devices (all trainers) the pairing bit is not used.

SimulANT+ is recommended over AntwareII for ANT+ profiles for basic use cases since it handles the channel setup and data encoding and decoding.

The Elite Suito should work fine with SimulANT+.      

Signature

Ian Haigh

Rank

Total Posts: 5

Joined 2021-02-26

PM

Can you please guide me trough what to do as I wasn't able to figure it out myself.

I see the dev0:USB2 connected      
RankRankRankRank

Total Posts: 283

Joined 2012-06-27

PM

The SimulANT+ download includes a user guide that walks you through all the steps. You are looking to add a "Fitness Equipment Display" simulator instead of the "Cadence Sensor" simulator added in the guide.      

Signature

Ian Haigh

Rank

Total Posts: 3

Joined 2021-06-10

PM

I have the same problem as you, did you find out how to solve it?